[ONLY BELGIUM] Connectivity issues with Proximus Belgium

Incident Report for INVERS GmbH

Resolved

Our devices connected to alternative networks.
Posted Mar 16, 2026 - 14:50 UTC

Update

Most CloudBoxxes switched network. We are working on a solution with our SIM provider.
Posted Mar 16, 2026 - 13:42 UTC

Update

We are currently experiencing issues with Proximus Belgium. CloudBoxxes should change network so impact should be minimal.
Posted Mar 16, 2026 - 12:10 UTC

Identified

We are currently experiencing issues with Proximus Belgium. CloudBoxxes should change network so impact should be minimal.
Posted Mar 16, 2026 - 12:10 UTC
This incident affected: Cellular Connectivity (CloudBoxx 1020 (LTE-M / 2G), CloudBoxx 4G (LTE / 2G), CloudBoxx 3G (3G / 2G)).