We are continuing to monitor for any further issues.
Posted May 19, 2026 - 22:05 UTC
Monitoring
The metrics are almost back to normal levels. The teams will continue to monitor the metrics and mark this incident as resolved if it remains stable over the next few hours.
Posted May 19, 2026 - 22:03 UTC
Update
It's taking longer for the remaining units to reconnect, but our teams are still on top of the situation
Posted May 19, 2026 - 21:37 UTC
Update
The situation regarding the remaining units continues to stabilize.
Posted May 19, 2026 - 20:52 UTC
Identified
Due to scheduled maintenance at a connectivity provider, all devices connected to that provider have been switched over to the alternative connectivity provider. There were brief interruptions during the switchover process. The situation has since stabilized, and the emergency teams and the connectivity team are working on the remaining unstable units.
Posted May 19, 2026 - 20:22 UTC
Update
We are seeing improvements regarding the communication success rate. We will keep monitoring the connectivity metrics.
Posted May 19, 2026 - 19:25 UTC
Update
We currently experience cellular connectivity issues with one of our providers. All CloudBoxxes connected via this provider are affected.
Posted May 19, 2026 - 19:06 UTC
Investigating
We currently experience cellular connectivity issues. We are investigating.