Monitoring cellular connectivity issues

Incident Report for INVERS GmbH

Resolved

This incident has been resolved.
Posted Oct 07, 2025 - 12:32 UTC

Monitoring

The cause has been identified and corrective actions have been taken. Our monitoring systems are showing services have returned to normal. We are currently monitoring to ensure stability.
Posted Oct 07, 2025 - 11:29 UTC

Update

Our connectivity provider is experiencing service degradation in the EU and NAM Region. The issue was reported to their partner carrier and investigation to determine the scope and cause is underway. We'll update you as soon as possible.
Posted Oct 07, 2025 - 10:14 UTC

Investigating

Our monitoring shows some cellular connectivity issues. Our partner confirmed that there is an issue on some data sessions. The 24/7 teams of INVERS and our partner are working on it, we post new updates once available.
Posted Oct 07, 2025 - 10:03 UTC
This incident affected: Cellular Connectivity (CloudBoxx 4G (LTE / 2G)).