Cellular connectivity issues in Spain and Portugal

Incident Report for INVERS GmbH

Resolved

The power outage in Spain and Portugal has been resolved which our metrics also confirm.
Posted Apr 29, 2025 - 06:25 UTC

Update

The connectivity issues are caused by a widespread power outage in Spain and Portugal. Other countries are not affected.
Posted Apr 28, 2025 - 12:50 UTC

Monitoring

Update: At least customers operating in spain are impacted, we can see ongoing issues with cellular connectivity in local networks.
Posted Apr 28, 2025 - 12:00 UTC

Identified

We currently experience cellular connectivity issues as reported by our connectivity partners. We are investigating.
Posted Apr 28, 2025 - 11:22 UTC
This incident affected: Cellular Connectivity (CloudBoxx 1020 (LTE-M / 2G), CloudBoxx 4G (LTE / 2G), CloudBoxx 3G (3G / 2G)).