Cellular connectivity issues only affecting Vodafone NL Netherlands

Incident Report for INVERS GmbH

Resolved

The graphs show that the radio network is functioning normally again.
Posted Aug 19, 2025 - 13:51 UTC

Update

Many devices have now switched to the other two providers. The Vodafone network remains unstable.
Posted Aug 19, 2025 - 13:27 UTC

Identified

We currently experience cellular connectivity issues in Netherlands since about 12:30 UTC. The devices connect to other more reliable networks.
Posted Aug 19, 2025 - 12:52 UTC
This incident affected: Cellular Connectivity (CloudBoxx 1020 (LTE-M / 2G), CloudBoxx 4G (LTE / 2G), CloudBoxx 3G (3G / 2G)).