Vodafone Netherlands is experiencing a total outage

Incident Report for INVERS GmbH

Resolved

This incident has been resolved.
Posted Jul 07, 2025 - 16:55 UTC

Update

Thanks to the managed connectivity of the CloudBoxx, almost all devices have connected to alternative networks in the Netherlands. We are monitoring the situation and will provide an update here once Vodafone has resolved the issue.
Posted Jul 07, 2025 - 14:20 UTC

Identified

Vodafone Netherlands is experiencing a total outage; devices are automatically switching to alternative networks.
Posted Jul 07, 2025 - 14:09 UTC
This incident affected: Cellular Connectivity (CloudBoxx 1020 (LTE-M / 2G), CloudBoxx 4G (LTE / 2G), CloudBoxx 3G (3G / 2G)).