Cellular connectivity issues in Spain, Hungary, Romania, Italy, Greece, Germany, Netherlands and Ireland for CloudBoxx 1020

Incident Report for INVERS GmbH

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 10:06 UTC

Investigating

INVERS has detected a service degradation affecting data services in Spain, Hungary, Romania, Italy, Greece, Germany, Netherlands and Ireland. Devices will switch to alternative routings to remain connected.
Posted Jul 02, 2025 - 08:03 UTC
This incident affected: Cellular Connectivity (CloudBoxx 1020 (LTE-M / 2G)).