Telekom Germany connectivity degradation

Incident Report for INVERS GmbH

Resolved

This incident has been resolved.
Posted Feb 12, 2025 - 14:00 UTC

Monitoring

Our partner has implemented a fix. We are already seeing improvements and are further monitoring the results.
Posted Feb 12, 2025 - 13:46 UTC

Identified

Our partner has identified the issue and will investigate with the network operator. Affected devices switch to other networks.
Posted Feb 12, 2025 - 13:30 UTC

Investigating

Our monitoring systems detected a connectivity degradation of Telekom Germany network. Devices using this network might face data communication issues. We are investigating with our partners.
Posted Feb 12, 2025 - 13:04 UTC
This incident affected: Cellular Connectivity (CloudBoxx 1020 (LTE-M / 2G)).